Verwenden von hale»connect Ressourcen in QGIS

Sowohl Open-Source- als auch proprietäre Geoinformationssysteme (GIS) unterstützen derzeit nur in begrenztem Rahmen die Nutzung von komplexen GML-Daten. Die Darstellung von Vektorgeometrien und zugehörigen Attribut-Daten wird von manchen GIS, wie beispielsweise QGIS, unterstützt. Klassische Operationen zur Geoverarbeitung sowie räumliche Analysen werden jedoch für komplexe GML-Daten nicht unterstützt. Für vertiefende Informationen zur Unterstützung von komplexen GML-Daten in GIS-Software, besuchen sie das CanIUse INSPIRE github repository. Harmonisierte INSPIRE-Daten liegen als komplexe GML-Daten vor. In diesem Tutorial lernen sie, wie hale»connect Darstellungs- und Download-Dienste in QGIS geladen werden können.

Dieses Tutorial verwendet:

  • die aktuelle Version 3.6.1 «Noosa» von QGIS, welche am 22.03.2019 veröffentlicht wurde
  • die aktuelle Version 1.2.0 des Plugins «QGIS GML Application Schema Toolbox»

Einen WMS darstellen

Um ihren hale»connect WMS in QGIS darzustellen, benötigen sie die URL zum Capabilities-Dokument ihres Services. Sie können auf die Capabilites-Dokumente für WMS 1.1.1 und 1.3.0 direkt aus dem «Darstellungs-Dienste»-Bereich ihres Datensatzes zugreifen. Um eine URL in die Zwischenablage zu kopieren, klicken sie auf das -Symbol rechts von der URL.

Öffnen sie QGIS und klicken sie auf das Layer-Menü. Wählen sie im «Layer»-Menü «Layer hinzufügen» und dann «WMS/WMTS-Layer hinzufügen…».

Klicken sie im erscheinenden Dialog «Datenquellenverwaltung» auf den «Neu»-Knopf. Daraufhin öffnet sich ein Dialog, in welchem sie eine neue WMS-Verbindung anlegen können. Geben sie ihrer neuen Verbindung einen Namen und geben sie die URL zu ihrem hale»connect-Dienst in das «URL»-Feld ein. Klicken sie «OK».

Ihr neuer Layer sollte nun oben im Dialog «Datenquellenverwaltung» angezeigt werden. Klicken sie auf den «Verbinden»-Knopf um auf den Dienst zuzugreifen. Sie können einen oder mehrere Layer auswählen, die ihrer Karte hinzugefügt werden sollen. Klicken sie auf den «Layerreihenfolge»-Reiter im Dialog «Datenquellenverwaltung» um die Darstellungsreihenfolge ihrer Layer festzulegen. Wenn sie fertig sind, klicken sie auf den «Hinzufügen»-Knopf in der unteren rechten Ecke des Dialogs «Datenquellenverwaltung» um die Daten zu ihrer Karte hinzuzufügen.

Die von ihnen ausgewählten Layer sollten in der «Layer»-Ansicht auf der linken Seite erscheinen. Die von QGIS dargestellte Legende wird aus der GetLegendGraphic-Abfrage an den WMS abgeleitet. Über einen Rechtsklick auf den Layer können sie unter «Eigenschaften…» mehr Informationen zu dem zugrundeliegenden Dienst einsehen.

Objekte in einem WMS abfragen

Nachdem sie ihre Darstellungs-Dienst-Layer zur Karte hinzugefügt haben, können sie diese unter Nutzung des «Objekte abfragen»-Knopfes erkunden.

Klicken sie auf den «Objekte abfragen»-Knopf. In einer Standard-QGIS-Installation befindet sich dieser in der obersten Werkzeugleiste. Er ist mit einem «info»-Symbol und einem weißen Pfeil gekennzeichnet. Klicken sie zunächst auf das «Objekte abfragen»-Symbol. Klicken sie anschließend in der «Layer»-Ansicht auf der linken Seite auf den Layer, dessen Daten sie erkunden möchten. Klicken sie dann auf ein Objekt in der Karte. Das Abfrageergebnis, das die Antwort des Dienstes auf eine GetFeatureInfo-Abfrage enthält, erscheint auf der rechten Seite. Wenn sie auf einen Bereich mit überlappenden Objekten klicken, werden die Ergebnisse für jedes Objekt aufgelistet. Mit hale»connect- Diensten haben sie die einzigartige Funktion, komplexe GML-Dateien über den hale»connect-FeatureExplorer zu erkunden. Klicken sie dazu im Dialog mit den Abfrageerebnissen für das Objekt von Interesse auf den «Details anzeigen»-Knopf. Der hale»connect-FeatureExplorer wird sich in einem neuen Dialog in QGIS öffnen. Er ermöglicht es ihnen, durch die verschiedenen Ebenen verschachtelter, komplexer GML-Daten zu navigieren, um referenzierte Ressourcen, Objekte, Codelisten oder Attribute, an denen sie interessiert sind, näher zu untersuchen.

Einen WFS darstellen

Um einen WFS, der auf komplexen GML-Dateien basiert, in QGIS darzustellen, müssen sie zunächst das Plugin «QGIS GML Application Schema Toolbox» installieren.

Das GML Application Schema Toolbox-Plugin installieren

Öffnen sie QGIS und klicken sie auf das «Erweiterungen»-Menü. Wählen sie im «Erweiterungen»-Menü «Erweiterungen verwalten und installieren…» aus. Der «Erweiterungen»-Dialog öffnet sich.

Geben sie «GML Application Schema Toolbox» in die Suchleiste ein. Wählen sie das Plugin aus und klicken sie auf «Erweiterung installieren» in der unteren rechten Ecke. Das QGIS-Plugin «GML Application Schema Toolbox» wird installiert.

Um auf das Plugin zuzugreifen, klicken sie auf das «Erweiterungen»-Menü in QGIS. Eine Option für den Zugriff auf das «QGIS GML Application Schema Toolbox» wurde dem «Erweiterungen»-Aufklappmenü hinzugefügt.

Das GML Application Schema Toolbox-Plugin nutzen

Um ihren hale»connect WFS in QGIS darstellen zu können, benötigen sie eine URL zu ihrem Download-Dienst. Sie können auf diese URL direkt aus dem «Download-Dienste»-Bereich ihres Datensatzes zugreifen. Um die URL in die Zwischenablage zu kopieren, klicken sie auf das -Symbol rechts von der URL.

Öffnen sie QGIS und klicken sie auf das «Erweiterungen»-Menü. Wählen sie im «Erweiterungen»-Menü «QGIS GML Application Schema Toolbox» und dann «Load (wizard)».

Wählen sie im Load wizard «WFS» aus und klicken sie auf «Weiter».

Klicken sie im «WFS Otions»-Menü auf den «New»-Knopf. Es öffnet sich ein Dialog, in welchem sie eine neue WFS-Verbindung hinzufügen können. Geben sie ihrer neuen Verbindung einen Namen und geben sie die URL zu ihrem hale»connect-Dienst in das «URL»-Feld ein. Klicken sie auf «OK».

Ihr neuer Layer sollte am oberen Ende des «WFS Options»-Menü erscheinen. Klicken sie auf den «Connect»-Knopf, um auf den Dienst zuzugreifen. Sie können eine oder mehrere Objektarten auswählen, die ihrer Karte hinzugefügt werden sollen. Sie können die Anzahl der abgefragten Objekte beschränken, indem sie die «Limit to»-Option anwählen. Wenn sie fertig sind, klicken sie auf den «Weiter»-Knopf. Wählen sie «Load in XML mode» und klicken sie auf den «Weiter»-Knopf.

Aktivieren sie im «XML options»-Menü «Swap X/Y axis». Das Standard-Koordinatenreferenzsystem von hale»connect-Diensten ist EPSG:4326. hale»connect nutzt dabei die Definition der EPSG-Datenbank für EPSG:4326 (WGS 84), während QGIS die Proj4-Definition für EPSG:4326 (WGS 84) nutzt, wodurch der Tausch der Achsen notwendig wird. Sie können das verwendete Koordinatenreferenzsystem im Reiter «Quelle» der Layer-Eigenschaften ändern, nachdem sie den WFS geladen haben. Klicken sie auf den «Abschließen»-Knopf in der unteren rechten Ecke des Load Wizard-Dialoges, um die Daten ihrer Karte hinzuzufügen.

Die Layer, die sie auswählen, sollten in der «Layer»-Ansicht auf der linken Seite erscheinen. Über einen Rechtsklick auf den Layer können sie unter «Eigenschaften…» mehr Informationen zu dem zugrundeliegenden Dienst einsehen.

Objekte in einem WFS abfragen

Nachdem sie ihre Download Service-Layer zur Karte hinzugefügt haben, können sie diese unter Nutzung des «Objekte abfragen»-Knopfes erkunden.

Klicken sie auf den «Objekte abfragen»-Knopf. In einer Standard-QGIS-Installation befindet sich dieser in der obersten Werkzeugleiste. Er ist mit einem «info»-Symbol und einem weißen Pfeil gekennzeichnet. Klicken sie zunächst auf das «Objekte abfragen»-Symbol. Klicken sie anschließend in der «Layer»-Ansicht auf der linken Seite auf den Layer, dessen Daten sie erkunden möchten. Klicken sie dann auf ein Objekt in der Karte. Das Abfrageergebnis, das die Antwort des Dienstes auf eine GetFeatureInfo-Abfrage enthält, erscheint auf der rechten Seite. Klicken sie auf das «Objektformular anzeigen»-Symbol, um die Attribute der Objektart, an der sie interessiert sind, einsehen zu können..

Es öffnet sich ein neuer Dialog in QGIS, der es ihnen ermöglicht durch die verschiedenen Ebenen verschachtelter, komplexer GML-Daten zu navigieren, um referenzierte Ressourcen, Objekte, Codelisten oder Attribute, an denen sie interessiert sind, näher zu untersuchen.

Mehr erfahren

QGIS führt eine eigene Dokumentation. Für mehr Information zur Nutzung von OGC-Diensten in QGIS, besuchen sie folgende Seite: Working with OGC Data